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Thank You For Purchasing
Weekly Class Schedule
Plugin!

You can read below a comprehensive guide with
detailed instructions about the Weekly Class
Schedule Plugin functionalities. Each section is
carefully explained, using helpful screenshots
when necessary. It contains everything you need

to have your plugin up and running in no time.

Online Documentation
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2. Free Support

We provide Free Customer Support for all Curly

Themes products through our quick and easy ticket

application interface. Please limit your inquiries to

problems related to the Weekly Class Schedule Plugin,

its setup and features. For any problems concerning

third-party plugins you should address the application’s

developer.
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Note: We can not offer support for custom CSS code customization.
You should ask a professional developer for aid if you require help
with advanced customization and programming.

Curly Themes offers a free ticket support application for all clients,
through a real-time license code automatic verification. The dedicated app
is fast and easy to use and includes an email notification feature. We will
let you know as soon as your inquiry has received an answer. Thanks to
our modern design, you can also upload images as an attachment to your
support ticket.

Before writing a ticket please get your Purchase Code and your License
Certificate:
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Before opening a new ticket, please make sure you have read through all
our documentation. Also, our FAQ section contains helpful answer to
questions we often receive from our customers. Following these steps is
in the users’ interest, as they will save valuable time. Still, we are always
happy to respond to any inquiries you may have related to the Weekly
Class Schedule Plugin.

3. Installing the Plugin


http://docs.curlythemes.com/weekly-class-schedule/#faq

O weekly-schedule-login

Before installing this plugin, you need to have a WordPress platform
already installed on your server. You can download it from
WordPress.org (', if you don’t have it already.

If you do not know how or you have problems with the installation, you
can access helpful information at:

e WordPress Codex &
e WPI101 Training Video &
e WordPress FAQ &

Once you have a working WordPress on your server, you have two
available ways to install this plugin.

3.1. FTP Upload

e Step 1 — Unzip the .zip package file you downloaded from Code
Canyon and locate the folder named weekly-class

e Step 2 — Upload this folder on your server in your WordPress
directory to /wp-content/plugins/

3.2. WordPress Upload
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The second way to install the plugin is by logging in from your website’s
http://yourwebsite.com/wp-admin/ to the WordPress Dashboard and:

e Step 1 — Go to Appearance > Plugins > Add New > Upload

e Step 2 — From there, you should select the file weekly-class.zip
from your computer

e Step 3 — After clicking the Install Now button, the installation
process is finished

e Step 4 — After installing the plugin is recommended to activate it by
clicking Activate Plugin

3.3. Activating the Weekly Class
Schedule Plugin

O weekly-schedule-activation



After you have completed the install process, in either of the two ways,
you need to activate it in case you didn’t already in the WordPress
installation method.

Log in to the WordPress Dashboard, go to Plugins >Installed Plugins
and select Weekly Class Schedule Plugin. Click the Activate button and
you can start using the plugin.

3.4. Importing the Demo Content

In the Weekly Class Schedule download package you can find
the Classes XML file (located in the demo content folder) that you can
use for a quick classes set up. Images are not included in the XML file.

To import the demo XML file, in the WordPress dashboard go to Tools >
Import and select to install from the list WordPress Importer. After the
installation is complete, select and upload the XML file. You can find the
Classes XML file in the demo content folder at root level in the Weekly
Class Schedule download package.

O import-leisure-demo-content

After this, the imported posts will appear in your Classes > All Classes
tab.

You can import also the demo schedules. In the Weekly Class
Schedule download package you can find the Schedule JSON file
(located in the demo content folder) that you can use for a quick
schedules set up.



To import the demo JSON file you should go at Classes > Schedule
Builder and click on the Backup Options button, to reveal a row of
buttons. Click on the Choose File button, to browse for the demo JSON
file, select it and click on the Import Backup. If you wish to create a
backup of your own schedules, you can use the Download Backup button,
that will export your schedules in a JSON file.

Schedule Builder s e

O Schedule Backup

4. Quick Plugin Setup

After installing and activating the Weekly Class Schedule plugin, the
options panel, named Classes, will appear in your dashboard on the left
sidebar, between the tabs Comments and Appearance:

O Weekly_Class_Schedule



You will be able to fill your schedule with events by adding Classes, just
like regular WP posts. Each Class post can be customized with various
options and you can assign Class Types, Locations and Instructors.

4.1. Adding a New Class

Add New Class
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© Add New Class

Go to Classes > Add New to create a new class entry, just like you would
create a normal post. After you publish the post, the entry will appear in
your schedule. You can customize the class with the Schedule Class
options box, on the right sidebar:

e Schedule Class — Use the schedule calendar to choose the date for
your Class.

e Starting Time — Use the select boxes to choose the starting time for
your Class. You can leave the No Repeat option active to make it a
one time event, or you can choose Repeat Weekly, to create a
Class that will be scheduled every week, at the same time, with the
same settings.

o Last Repeat Date — If you set the event as Repeat Weekly, you
can use this field to choose a last repeat date. This will be the last
date when the event will be displayed in the schedule.

e Class Duration — Use the bar to select how long is the Class. The
minimum length is 10 minutes and the maximum is 6 hours.

e Status — If you want to display the event as canceled, you can use
this select box to switch from Live to Canceled. If it is a Repeat
Weekly class, all classes will be canceled. A canceled class will
appear in your schedule with all the words crossed out. The option
Canceled Dates is only for weekly repeatable events and allows
scheduling dates when the event will be canceled, without affecting
the weekly recurrence.



For each class, from the right side boxes, you can assign Class Types,
Locations and Instructors. Class Types can be first level or have a Parent
Class. You can create Class Types, Locations and Instructors directly from
the boxes or through the dedicated options panel in the Classes module.

Class Settings

e Class Image — You can assign a featured image for the class. This
will be displayed in the pop-up modal window for all schedule and
directly in the schedule for the Plain List style and the Events
Carousel.

e Action Button — You can create a Call-to-action button for the class
with one of the four available functionalities: Go to page, Go to
custom URL, Email or Download iCal Event.

If you wish to add a map for the class, you can configure it in the Map
Details tab with the following options:

e Map Latitude — Enter the latitude coordinates so the map will show
your desired location.

e Map Longitude — Enter the longitude coordinates so the map will
show your desired location.

e Map Type — Choose one of the four map types available: Roadmap,
Satellite, Hybrid and Terrain. Default is set to Roadmap.

e Map Color Theme — Choose a color theme for the map: Light, Dark
or leave it Default.

e Map Zoom — Enter the zoom level of the map, from 1 to 18.
Please note, the map will be displayed in the pop-up modal window and it

will appear only if you set a valid value for latitude and longitude
coordinates.

For the Events Carousel schedule style, you can add an Excerpt, that will

be displayed in the class carousel element, below the image. The Excerpt
tab is at the bottom of the page, below Individual Page Settings.

4.2. Class Types

Go to Classes > Class Types to create and manage your class types.
Those will be displayed, for each class, in your schedule timetable.

e Name — Type in the name for your class type. Examples: Fitness,
Yoga, Latino.



e Slug — The link slug for the class type will be auto generated. You
can type in a custom one.

e Parent — If you want, you can assign a parent to the class type.

e Description — If you want, you can add a description for the
class type. This will be displayed in a pop-up, when clicking on the
Class Type name in the schedule. Also, you can make the Class
Type name a link, if the Description field’s content is just an URL.

e Color — If you want to display some classes with a different color
in the schedule, you can assign a color to the Class Type. The
coloring style will depend on the Schedule Style used, as each style
has its own particular way to display colored classes. The color of
the class will override the color of the parent class.

4.3. Locations

Go to Classes > Locations to create and manage your locations. Those
will be displayed, for each class, in your schedule timetable.

e Name - Type in the name for your location. Examples: Main
Room, Yoga Room, Red Room.

e Slug — The link slug for the location will be auto generated. You
can type in a custom one.

e Description — If you want, you can add a description for the
location. This will be displayed in a pop-up, when clicking on the
Location name in the schedule. Also, you can make the
Location name a link, if the Location field’s content is just an URL.

4.4. Instructors

Go to Classes > Instructors to create and manage your instructors. Those
will be displayed, for each class, in your schedule timetable.

e Name — Type in the name for your instructor. Examples: Mark
Taylor, Diana Johnson.

e Slug — The link slug for the instructor will be auto generated. You
can type in a custom one.

e Description — If you want, you can add a description for the
instructor. This will be displayed in a pop-up, when clicking on the
Instructor name in the schedule. Also, you can make the
Instructor name a link, if the Instructor field’s content is just an
URL.

4.5. Class Settings



Classes’ content will be displayed by default in a pop up window. If you
wish to use a class page instead of the pop up window, you can go to
Classes > Settings and customize the page with the following options:

¢ Event Single Page — If you check the Allow events to have a
public single page box, your classes will have a page with URL.
To activate it, you will need to go in the Schedule Builder, at Modal
Options, and select Disabled.

¢ Event Page Template — Use this select box to choose the page
template for all your class pages.

e Event Page Slug — Type in the slug for the classes URL. Default is
class.

e Events Box Position — Choose the position of the info box in the
class page. Available options are Center, Left and Right. You can
also Disable it.

e Special Color — If you have the info box active, you can choose
here the color for elements, like buttons or titles.

e Event Page Date Format — If you have the info box active, you
can use this field to customize the data format.

e Show Time in 12h Format — Use this checkbox to switch from a
24-hours format time to a 12-hour AM / PM format.

e Show Ending Time / Duration / Location / Instructor / Map — If
you have the info box active, you can use these select boxes to
show/hide info.

If you check the box to display a map, you can customize it with the
following options:

e Map Theme — Choose a color theme for the map: Light or Dark.
e Map Zoom Level — Enter the zoom level of the map. Default is 15.

e Map Type — Choose one of the map types available: Roadmap or
Satellite.

5. Schedule Builder
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After creating your classes, you should go at Classes > Schedule Builder
and create one or several schedules, with the settings and style of your
choice. You can easily manage the schedules from this tab, by adding a
new one or deleting, duplicating or editing schedules you already created.
Once you have your schedule built, you can use a simple shortcode to
place it in a page, like this:

[wcs—-schedule id=1]

If you have the Visual Composer plugin installed on your platform, you
can insert the schedule through our custom Visual Composer element.
Click on the + button to add a VC element, select Weekly Class Schedule
element from the list, and add it in the page.
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The only option you need to configure is the Choose Schedule select box,
where you can select which schedule you want.

¥ + = Do

Weekly Class Schedule Settings - Sisator

© VC Element Box

The schedule can be customized through the following options:

e Schedule Style — You have 9 styles available for the schedule, each
with a different layout, design and info displayed. Depending on
your business and purpose of the schedule, you can choose the
appropriate one. There are 3 list styles: Plain List, Compact List
and Large List, a Weekly Schedule that is similar to a calendar and
Weekly Tabs, that splits the classes with a tab for each day. The new
styles are Events Carousel, that allows a graphical carousel display,

Daily Agenda, a simple calendar view, Masonry Grid, a dynamic
grid with images and Timeline, a simple vertical timeline display.

e Schedule Contents — The 3 tabs (Class Types, Locations and
Instructors) allow you to define which classes will appear in the
default schedule display. If you select only several Class Types /
Locations / Instructors, then only the classes assigned with a
selected Class Type / Location / Instructor will appear.

¢ Available Filters — The 3 tabs (Class Types, Locations and
Instructors) allow you to define which options will appear in the
filters. Please note, you have to allow filters to display them.

e Type / Location / Instructor / Label — You can use these fields to
type in the label for the Class Types / Locations / Instructors info in
your schedule.

e Type / Location / Instructor / Filter Label — You can use these
fields to type in the label for the Class Types / Locations /
Instructors filters in your schedule.

e Days of The Week Filter Label — You can type in the label for the
filter allowing to sort with the 7 days of the week.

e Time of The Day Filter Label — You can type in the label for the
filter allowing to sort with the Morning, Afternoon and Evening
options.



More Classes Button Label — You can type in the label for the
button which loads aditional classes, that were not scheduled in the
initial time selection.

Filters Toggle Button Label — You can type in the label for the
button which allows you to show or hide the filters.

Info Button Label — You can type in the label for the button which
opens the pop-up description, displayed next to each class.

Nothing to Show Message — You can type in the message
displayed when there are no available classes matching the
selection.

How many days to show? — Use this select box to choose the
period of time that your schedule will display. Available options
are: Show all Days, 1/2/3/4/5/6 Daysand 1/2/3/4 Weeks.
Please note, if you use the Show all Days option, the schedule will
display all classes, with the repetitive classes displayed only once.

Display Options — You can use the Show Schedule Title / Ending
Time / Duration / More Button / Class Types / Locations /
Instructors / Description / Excerpt options to display or not the
desired info in the schedule. Show 12-hour Clock allows you to
switch from a 24-hours format time to a 12-hour AM / PM format.

Show Past Events — If you activate this option, your schedule will
display also today events that are already over. Activating this
option will reveal Past Events Starting Date calendar, that you can
use to display past days events, by choosing the earliest past date of
the schedule.

Date Format — For 6 schedule styles (Compact List, Large List,
Weekly Tabs, Timeline, Masonry Grid and Events Carousel) you
can customize the date format in the schedule, according to
Moment.js supported date formats.

Filter Options — You can use the Show Type / Instructors /
Locations / Day of the Week / Time of the Day Filter options to
display or not the desired filters. Please note, by displaying or not a
filter, you might restrict the classes that the visitors will be able to
see. You can also choose switches instead of checkboxes and
display the filters expanded.

Filters Position — If you allow filters, you can use this to choose
the filters location. You have 3 available options : Left, Center and
Right.

Modal Options — You have two available choices for the pop-up
modal window style: Small Image or Large Image. You can also
Disable it, if you want to use class pages, instead of the pop up
window.

Enabled Light Modal Window — You can use this option to


https://momentjs.com/docs/#/displaying/

activate a light colored pop-up modal window.

e Show Starting & Ending Time / Duration / Class Types /
Locations / Instructors — You can use these options to display only
the info you want in the pop up window.

e Date Format — You can use this field to change the date format for
the pop up window., according to
Moment.js supported date formats.

e General Coloring — Text / Special Color — Use these options to
choose the schedule colors. The special colors is used for important
elements, like titles, buttons, etc.

e Weekdays Coloring — If you want to display all classes in a day
with a custom color, you can assign here a color for any weekday
you want.

e Grid / Timeline Item Bg Color — If you use the Masonry Grid or
Timeline styles, you can use this option to select a color for the
elements background.

Carousel Options

If you select the Events Carousel schedule style, the filter options will be
replaced with several custom options, that are relevant only to the
carousel.

e Show Navigation Arrows — You can use this option to display or
hide navigation arrows on the left and right side of the carousel.

e Show Dots Arrows — You can use this option to display or hide
navigation dots below the carousel.

e Enable Autoplay — You can use this option to activate the autoplay
for the carousel.

e Enable Loop Play — You can use this option to activate the loop for
the carousel.

e Autoplay Speed — You can use the select box to choose a speed
level for the carousel autoplay: Fast 1-4, Normal or Slow 1-5.

o X-Large/Large / Medium / Small Devices Items — Use these
select boxes to choose the number of elements to be displayed on
the carousel on very large/ large / medium / small screen devices.

¢ Distance Between Items — Use this select box to choose the space
in pixels between two carousel elements.

e Stage Padding — Use this select box to choose the padding of the
carousel.

e Carousel Bg / Nav Color — Besides text and special color, the
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carousel elements accept a background and a navigation color.

Masonry Grid Options

If you select the Masonry Grid schedule style, you can choose how many
elements should be on a grid line, for each screen size.

e Large / Medium / Small Devices Items — Use these slide bars to
select the number of elements to be displayed on a grid line on large
/ medium / small screen devices.

e Grid Item Bg Color — Besides text and special color, the
grid elements accept a background color.

6. Booking

To enable the booking functionality, you need to install and activate
WooCommerce plugin. If you do not have WooCommerce installed, you
can see the product page here and find out more information about it.
Also, you can read the WooCommerce instructions and documentations
here.

6.1. Creating Tickets

.......

© Schedule Ticket


https://www.woothemes.com/woocommerce/
https://docs.woothemes.com/documentation/plugins/woocommerce/

If you have WooCommerce active on your platform, you should see the
tab Products in your dashboard, right below the tab WooCommerce. Go
to Products > Add Product and scroll down to the Product Data section
and select Schedule Ticket as the type of product, to create tickets for
your classes.

The Schedule Ticket is a custom type of product that allows only basic
options in the Product Data section. You can use the General tab to set the
SKU and the price.

NOTE: You should use the Catalog Visibility option, from the
Publish options box at the top right, to set the product as Hidden.
This is a mandatory option to ensure the correct functionality of the
booking feature.

Praduet Togs

O Catalog Visibility

6.2. Assigning Tickets to Classes
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© WooCommerce Tickets Tab

After you have created at least one ticket, you can edit your classes and
assign it. Edit the class and scroll down to Class Settings section and click
on the WooCommerce Tickets tab. You can customize it with the
following options:

7.

Capacity — Use this field to type in the number of tickets you have
available for this class. After all of them are booked, tickets for this
class will no longer be available. If you leave this field empty, the
booking functionality will not be active for this class.

Button Label — Type in the name of your Booking button. If you
leave the field empty, the button will not be displayed.

Sold Out Label — Type in the name of your Booking button when
tickets are no longer available. If you leave the field empty, the
button will not be displayed after all tickets are booked.

Sold Out Link — If you wish to add a link to the Sold Out button,
you can type it here. If you leave the field empty, the button will not
be clickable.

WooCommerce Event Ticket — Use this select box to assign a
ticket for the class. NOTE: You should first create, in the Products
tab, a Schedule Ticket with the Catalog visibility as Hidden.

A place in your class will have the price that you set for the ticket.

FAQ

1. How can | populate the timetable with events?



You can fill the timetable by adding Classes, just like you would add
regular WP posts. Go to Classes > Add New to create new entries. If you
can’t find the Classes options panel in the dashboard, on the left sidebar,
you need to activate the plugin.

2. How can | make a class to be scheduled for every
week, at the same time?

When you add a new Class, from the Schedule Class options box on the
right, you can choose the date and the time. Next to the ylarting time
select boxes, you can find a select box that makes the class Repeat
Weekly. If you select this option, the class will be scheduled for every
week, at the same time, with the same settings.

3. Can | show a class as canceled in the timetable?

Yes, if you check the box Show this event as canceled. When editing a
Class, you can find the check box on the Schedule Class options panel,
on the right. If it is a class that is repeated weekly, all classes will appear
as canceled. Classes displayed as canceled are distinctly marked in the
timetable, usually with a shadow effect.

4. Is there a limit to how many Class Types, Locations
or Instructors | can assign to a Class?

The plugin does not limit how many you can assign, but you should take
in to consideration how this will affect the timetable design.

5. How can | display the timetable through shortcode?

After you create a timetable in the Schedule Builder, a shortcode will be
auto-generated and it will be displayed on the top-right corner of the
builder, under the How many days to show? option. The shortcode will



have a simple structure, something like [wes-schedule id=1] and you can
place it in any area that accepts shortcodes.

6. How can | display the timetable with Visual
Composer?

After you create a timetable in the Schedule Builder, you can add it in
your page just like you would add any other Visual Composer element.
Look for the Weekly Class Schedule element in the list. The element will
display a select box, for an easy integration.

7. Can | choose another layout for the timetable?

You can choose one of the nine available styles. All layouts can display
almost the same amount of information, only the style is different. You
should try all to decide which one is the right one for your business.

8. Can | display a different image for each of my
classes?

Yes, you can assign a featured image for each class and it will be
displayed in the pop-up modal window. Still, if you want to display the
images in the schedule, you will have to use the Plain List schedule style,
as this is the only one designed for image display. The Events Carousel
and Masonry Grid can display images also.

9. Do | have any interactions available for my classes?

Yes, you can create a custom Call-to-action button with one of the several
available functions: internal or external link, mail to function and iCal
Event. These functions allow visitors to send reservation mails, add the
class directly to their calendar or visit a custom page for the event.



10. Can | display custom content for Instructors,
Locations or Class Types?

Yes, you can add a description that will be displayed in a pop-up, when
clicking on the Instructor / Location / Class Type name in the schedule.
Also, you can make it a link, if the Description field’s content is just an
URL.

11. How can | display a schedule with only some of my
classes?

When you create one in the Schedule Builder, you can define the classes
with the help of the Schedule Contents tabs. If you select only several
Class Types / Locations / Instructors, then only the classes assigned with a
selected Class Type / Location / Instructor will appear.

12. How can | change the starting day of the schedule?

The starting day of the schedule, depending on the schedule style, is either
the current day or the first day of the week, according to your WordPress
settings. If you change the first day of the week at Settings > General >
Week Starts On, the change will reflect in the schedule display.

13. How can | change the time displayed for my classes
to a 12-hour AM / PM clock?

You can choose between 12-hour clock and 24-hour clock for each
schedule individually, in the Schedule Builder. On the right side, under
the Display Options section, you can find the Show 12-hour Clock
switcher. Turning this option On will switch your schedule to a 12-hour
AM / PM clock.

14. How can | export / import my schedules?



In the Classes > Schedule Builder tab, under the schedules list, you will
find the Backup Options button. Clicking this will display a set of buttons.
If you wish to export your schedules, you can click on the Download
Backup button and your data will be saved in a JSON file. You can then
easily import the data by clicking on the Choose File button, browsing
and selecting the JSON file and then clicking on the Import Backup
Button.

15. How can | use a color for a particular class?

You can change the color of a class in the schedule by assigning a Class
Type to that class and assigning a custom color to that Class Type. The
coloring style will depend on the Schedule Style used, as each style has its
own particular way to display colored classes. The color of the class will
override the color of the parent class. Another method is through color
coding the days. You can use the Weekdays Coloring tab in the Schedule
Builder to assign a color for a specific day.

16. How can | set a map for a particular class?

You can assign a map individually for each class, through the Map Details
tab, right below the content area. The map will be displayed in the pop-up
modal window and it will appear only if you set a valid value for latitude
and longitude coordinates.

17. How can | customize the design on my Events
Carousel elements?

The Events Carousel schedule style doesn’t have filters, but it allows
some additional graphical customizations. In the Schedule Builder, you
can choose a background color for the elements and you can edit the Class
post to add an Excerpt. If you don’t use Excerpt, the carousel will display
the first lines of text in the class description.



18. How can | make multiple copies of a class?

In the Classes list, if you mouse over a class you will display the
Duplicate Class button. Clicking on this button will create a copy of that
class, with the same starting date, description, taxonomies, featured
image, etc. You can edit this copy to change what you need and create
similar classes very fast.

19. What do | need to set up booking for my classes?

Our booking functionality works through WooCommerce products, so
you need to install and activate the WooCommerce plugin on your
platform. You don’t need to do any special customizations for
WooCommerce, it will work fine with the default settings.

20. How should I create a ticket for my classes?

The ticket is an WooCommerce product. When you create the product,
you should go at Product Data and set it as a Schedule Ticket. You should
also use the Catalog Visibility option to set it as Hidden. It is important to
select both these options. Otherwise you will not be able to use this ticket
for your classes.

7.1. Moment.js date format

Token Output

Month M 12...1112
Mo Ist2nd ... 11th 12th
MM 0102...1112
MMM Jan Feb ... Nov Dec

MMMM January February ... November
December

Quarter Q 1234



Day of
Month

Day of
Year

Day of
Week

Day of
Week
(Locale)

Day of
Week
IS0O)

Week of
Year

Week of
Year (ISO)

Qo

Do
DD

DDD

DDDo

DDDD

do
dd
ddd

dddd

¢

W

WO

Ww

WW

1st 2nd 3rd 4th

12...3031

1st 2nd ... 30th 31st
0102...3031

12...364365

Ist 2nd ... 364th 365th
001 002 ... 364 365

01...56

Oth 1st ... 5th 6th
Su Mo ... Fr Sa
Sun Mon ... Fri Sat

Sunday Monday ... Friday Saturday

01...56
12...67
12...5253

Ist2nd ... 52nd 53rd

0102...5253

12...5253

1st2nd ... 52nd 53rd

0102...5253



Year

Week Year

Week Year
(ISO)

AM/PM

Hour

Minute

Second

Fractional
Second

YY

YYYY

24

2424244

GG

GGGG

HH

hh

mm

SS

SS

SSS

7071 ...29 30
1970 1971 ... 2029 2030

1970 1971 ... 9999 +10000 +10001

Note: This complies with the ISO 8601
standard for dates past the year 9999

7071 ...29 30
1970 1971 ... 2029 2030

7071 ...29 30

1970 1971 ... 2029 2030
AM PM

am pm
01...2223
0001 ...2223
12...1112
0102...1112
12...2324
0102...2324
01...5859
0001 ... 58 59
01...5859
0001 ... 58 59

01...89

0001 ... 9899

000 001 ... 998 999



SSSS ... 000[0..] 001[0..] ... 998[0..] 999[0..]

SSSSSSSSS
Time Zone 7z orzz EST CST ... MST PST
Note: as of 1.6.0, the z/zz format tokens
have been deprecated from plain moment
objects. Read more about it here.
However, they do work if you are using a
specific time zone with the moment-
timezone addon.
Z -07:00 -06:00 ... +06:00 +07:00
77 -0700 -0600 ... +0600 +0700
Unix X 1360013296
Timestamp
Unix X 1360013296123
Millisecond
Timestamp

8. Credits

The Weekly Class Schedule Plugin was developed by Curly Themes.
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9. Release Notes:

Weekly Class Schedule 2.0 (March 23, 2017)


https://github.com/moment/moment/issues/162

Note: Date Format fields now support only Moment.]js
date formats. If you are updating from a previous
version with WP standard date formats, you need to
edit the Date Format fields and add a date format
according to this table: Moment js date format

& Incompatible API changes. We’ve rewritten both
frontend and backend with reactive JS technology.
This should improve the general performances of the
plugin in terms of speed and usability.

& The Date Format fields support now only Moment.js
date formats.

& Added a Date Format field for Large List and
Timeline schedule styles.

@ Past Events Archive has been replaced with the
Show Past Events option, which allows more
flexibility.

@ Fixed a bug related to WooCommerce Add Ticket to
Cart redirect.

@ Fixed a bug related to pop up modal window class
info.

@ Fixed a bug related to language file translation.
@ Fixed a bug related to location and instructor
content selection in the schedule builder.

@ Fixed a bug related to the Class Type children
structure.

@ Fixed a bug related to Events

Carousel navigation.

@ Minor bug fixes.

Weekly Class Schedule 1.8 (January 18, 2017)
& Incompatible API changes.
We’'ve completely rewritten the plugin code to make
it more plugable and easier to customize. The front-
end filters and schedule builder options are more
dynamic now.
@ Added the 12 hours clock option for class pages.
@ Fixed a bug related to UTC+12 and UTC+13
timezones.
@ Fixed a bug related to Timeline, Compact List and
Large List styling for Show More classes.
@ Fixed a bug related to Action Button mailing
functionality.
@ Fixed a bug related to the Class Type pop up

window.


http://docs.curlythemes.com/weekly-class-schedule/#moment-js-date-format

@ Fixed a bug related to Masonry Grid filters.
@ Minor bug fixes.

Weekly Class Schedule 1.7.3 (August 19, 2016)
& Added Show Filters Expanded option, that
allows loading the schedule with the filters already
expanded.
@ Fixed a bug related to left and right filters
position.
@ Fixed a bug related to Google Maps API.
@ Updated gmaps3 to 7.1.
@ Added the possibility to break lines in the class
excerpt.

@ Minor bug fixes.

Weekly Class Schedule 1.7 (June 2, 2016)
& Added Class Page functionality, that allows
replacing the pop up window with a class page.
@ Added Last Repeat Date option, that allows
settings a last date for a weekly repeatable event.

@ Minor bug fixes.

Weekly Class Schedule 1.6 (May 16, 2016)
& Added Booking functionality, that allows booking
tickets through WooCommerce.
@ Added Date Format option, that allows changing
the date format for Compact List, Weekly Tabs and
Events Carousel.
@ Fixed an issue with the pop up window info
display .
@ Fixed an issue with the iCal button.
@ Improved the Weekly Schedule style
responsiveness.

@ Minor bug fixes.

Weekly Class Schedule 1.4 (April 5, 2016)
@ Added the Timeline schedule style, that allows
classes display in a simple, vertical timeline.
& Added the Canceled Dates option, that
allows canceling recurrent future events.
@ Added Date Format option, that allows choosing a
custom date format for the modal box.
& Added several Modal Options, that allow showing
or hiding info in the pop up window.



@ Fixed an issue with the Calendar display on
certain timezones.

@ Fixed an issue with the Type Label display for
Large List style.

@ Fixed an issue with the map display.
@ Minor bug fixes.

Weekly Class Schedule 1.3.2 (March 21, 2016)

@ Added the Masonry Grid schedule style, that
allows classes display as grid elements.

& Added the Duplicate option, that allows creating
multiple copies of a class.

@ Added the Past Events option, that allows
creating a schedule with only finished events.

& Improved the general Schedule compatibility.
@ Fixed an issue with the Weekly Schedule style.
@ Fixed several display issues.

@ Fixed an issue with the pop-up modal window 12
hours clock display.

@ Minor bug fixes.

Weekly Class Schedule 1.3 (March 3, 2016)

@ Added the Events Carousel schedule style, that
allows classes display as carousel elements.

& Added the Daily Agenda schedule style, that
allows classes display in a simple daily calendar.

@ Added the Starting column in the All Classes
list, that allows sorting classes by starting time.

& Improved the general Schedule Builder
functionality, with more dynamic options.

@ Reworked the Class options panel, for an easier
customization.

@ Fixed several compatibility issues.

@ Fixed an issue with the pop-up modal window in
Compact List style.

@ Minor bug fixes.

Weekly Class Schedule 1.2 (February 22, 2016)
& Added the Map Details tab for classes, that
allows you to display a Google Map for your class.
& Added the Weekdays Color option in the Schedule
Builder, that allows you to assign a color to a day.
@ Fixed a color coding CSS bug.
@ Minor bug fixes.



Weekly Class Schedule 1.1 (February 18, 2016)
@ Added the Backup functionality to Schedule
Builder, that allows importing and exporting
schedules.
& Added the Color option to Class Types panel, that
allows you to use different colors for classes.
& Added the Show 12-hour Clock option in the
Schedule Builder, that allows you to use a 1l2-hour
AM / PM time for your classes.
@ Added Classes XML file in the download package,
that includes the demo classes.
& Added Schedule JSON file in the download package,
that includes the demo schedules.

@ Minor bug fixes.

Initial Release (February 13, 2016)

Last Documentation Update: Thursday, March 23,2017



